2021-04-16 Проблеми при стартиране на ERP.net Desktop Client след ъпдейт на Microsoft Edge

Проблемът е отстранен за версия 2020 SP10, която поетапно ще бъде качена на всички потребители.

 

След последния ъпдейт на Microsoft Edge до версия 90.0.818.39 възникнаха проблеми със стартирането на ERP.net Desktop Client. При логване в системата излиза грешка:

Failed to create webview environment. Result: -2147024894

 

 

Временно заобикаляне на проблема

В случай, че сте засегнати от проблема, като спешно решение може да се изпълни следната команда в cmd.exe:

ren "%LocalAppData%\ERP.net Desktop Client\native" "_native"
 
Или да се стартира следният BAT файл, който я изпълнява дирeктно.
FixErpNetStarting.bat
 

В случай, че използвате POS клиента

 
В случай, че използвате приложението "EnterpriseOne POS", единственият вариант е използване на посочения .BAT файл - той оправя проблема както за нормалния, така и за POS клиента.
 

В случай, че използвате сървърна операционна система

 
Ако стартирате клиентското приложение на сървърна операционна система (като Windows Terminal Server например), то е необходима още една настройка, която позволява използването на Internet Explorer.
 
Подробности може да намерите в следния топик:
https://support.erp.bg/hc/bg/articles/360021195299
 
 
 
 

 

Беше ли полезна тази статия?
1 от 1 считат материала за полезен
Имате още въпроси? Подаване на заявка

5 Коментари

  • 0
    Avatar
    Teodora Rakova

    Здравейте, 

    Има ли вариант за коригиране на проблема при потребители с Win 7?

    При тях, след прилагане на BAT-файла и опит за вход в системата се връща грешка "Тази страница не може да се покаже":

  • 0
    Avatar
    Ivelin Ivanov [ERP.BG]

    Здравей,

    Не би трябвало да има проблеми при Windows 7 различни от тези в Windows 10. Нека се опита за се изпълни процедурата от този топик:

    https://support.erp.bg/hc/bg/articles/360021195299

     

  • 0
    Avatar
    Ivelin Ivanov [ERP.BG]

    Иначе аз тествах на Windows 7 и работи фикса. Може да има някакъв друг проблем - на снимката не се вижда никакъв адрес за Е1 сървър.

     

  • 0
    Avatar
    Teodora Rakova

    Здравейте,

    Може ли даа се ползва функционалност Дискусии при деинсталиран или неактуален Edge? Има ли нужда от настройки?

    Благодаря!

  • 1
    Avatar
    Ivan Argentinski [ERP.BG]

    В SP9, след прилагане на фикса, функционалността за Дискусии и Уеб приложения е спряно въобще.

    В SP10, функционалността е налична отново. Вече не зависи пряко от Microsoft Edge, а от отделен компонент, наречен Microsoft Edge WebView2. Инсталирането на този компонент се прави директно от панела. Това е най-модерният компонент на Майкрософт за интеграция на браузър функционалност.

    За съжаление, се наложи да го вградим спешно. Съответно, има все още няколко дребни бъгчета за доизчистване при интеграцията. Конкретно, проблеми са, че панелът иска логин, макар и да сме се вече логнали в системата; самата инсталация приканва за "Edge", а всъщност инсталира "Webview" и т.н. Нямахме време да изчистим всичко, защото ситуацията беше критична.

    Но като цяло, нещата вече работят.

Влезте в услугата, за да оставите коментар.
Powered by Zendesk